wordpress

  1. Wordpress websites, Raleigh NC

    WordPress Site Security Basics Everyone Needs to Know

    Ever wonder why a hacker would be interested in your website? Think your site is too small or ‘insignificant’ to be hacked?

    It is not uncommon to think a ‘small’ site is immune to malevolent hackers. But the truth is that no site is immune, and small sites are just as likely to fall victim to the attacks as larger ones.

    Knowing some basic information about hacking and how to protect your site is the first step to decreasing your security risk. Here are answers to some common questions about site security:

  2. WordPress SEO Plugin Critical Security Update

    The WordPress SEO Plugin by Yoast is a very powerful and popular plugin for WordPress. It’s used on more than a million websites. Recently it was announced that there is a serious security vulnerability in the plugin. An update is already available, but you must update the plugin in your WordPress dashboard to correct the problem. Read more about it here.
  3. ecommerce, photography, Raleigh NC

    WooCommerce Introduces Tool for Photographers

    Using WooCommerce for selling photographs online has taken a leap forward with the introduction of its new Photography extension.

    WooCommerce is one of the leading eCommerce plugins for sites built with WordPress. The new Photography extension adds custom capabilities making the platform more user-friendly for photographers selling their images online.

  4. WordPress Update 3.9.2

    There have been some nasty hacks circulating the interwebs targeting WordPress recently. If you are running WordPress, we recommend that you update your site to 3.9.2 as soon as possible, as well as all your plugins. If you are currently subscribed to our WordPress update service, then we will handle that for you. Note, that is a different service than hosting. If you are not sure if you are getting updated by us, contact us to inquire about that.

    Here’s the full info from WordPress.

  5. Better WP Security Changing to iThemes Security

    We’re a big fan of the plugin known as Better WP Security. If we’ve developed a WordPress site for you, chances are your site uses it.

    On March 17, the authors of this plugin announced a name change to iThemes Security. For sites using the plugin with the previous name, WordPress will automatically deactivate it with the next upgrade. All sites with the plugin will be affected. The impact in not systems critical, but we wanted to give our clients a heads up! All you need to do is reactivate it with the new name.

    If you’d like more info about the update check out this link:

    http://ithemes.com/2014/03/17/better-wp-security-plugin-changing-ithemes-security-need-know/

  6. WordPress Update – Version 3.7 “Basie”

    There’s been a major update for WordPress recently. Here is the press release from the WordPress team:

    Version 3.7 of WordPress, named “Basie” in honor of Count Basie, is available for download or update in your WordPress dashboard. This release features some of the most important architectural updates we’ve made to date.

  7. Managed Optimized Wordpress Hosting in Raleigh NC

    WordPress 3.6.1 Maintenance and Security Release

    Check out this information from the WordPress team regarding the recent 3.6.1 release:

    After nearly 7 million downloads of WordPress 3.6, we are pleased to announce the availability of version 3.6.1. This maintenance release fixes 13 bugs in version 3.6, which was a very smooth release.

  8. Tighten Up Your WordPress Website Security

    The basis of more than 73 million websites, WordPress is one of the most widely used Content Management Systems. It’s popular with web designers and end-users alike for numerous reasons. Unfortunately, its popularity can make it a target for hackers.

    Taking proactive steps to secure your WordPress files is vital to protecting your web presence and your business. To start, we strongly advise you keep WordPress up-to-date on your site (new security features are often released with each version) and choose passwords that are difficult for hackers to guess.